
<!doctype html>
<html>
<head>
	<meta charset="utf-8">
	<base href="https://www.realwire.com/" />

	<meta name="title" content="&#8220;BE Deutsche Hospitality&#8221; &#8211; exclusively for hotel partners, franchisees and investors " />
	<meta name="description" content="Deutsche Hospitality offers new service solutions and a transparent fee model
Frankfurt am Main, 9 December 2021 Deutsche Hospitality is undertaking a massive expansion of the services it provides to hotel partners and investors in the areas of franchise, management and lease agreements..." />
	<link rel="canonical" href="https://www.realwire.com/releases/BE-Deutsche-Hospitality-exclusively-for-hotel-partners" />
	<meta name="keywords" content="" />
	<meta name="robots" content="NOODP" />
	<meta name="medium" content="news" />
	<link rel="image_src" href="https://www.realwire.com/images/logo.gif" />
	<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:image" content="https://www.realwire.com/twitter_writeitfiles/Be-Deutsche-Hospitality.jpg" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image:height" content="400" />

	<meta name="twitter:site" content="@RealWire" />
	<meta property="og:title" content="Deutsche Hospitality | &#8220;BE Deutsche Hospitality&#8221; &#8211; exclusively for hotel partners, franchisees and investors " />
	<meta property="og:description" content="Deutsche Hospitality offers new service solutions and a transparent fee model
Frankfurt am Main, 9 December 2021 Deutsche Hospitality is undertaking a massive expansion of the services it provides to hotel partners and investors in the areas of franchise, management and lease agreements" />
	<meta property="og:url" content="https://www.realwire.com/releases/BE-Deutsche-Hospitality-exclusively-for-hotel-partners" />
	<meta property="og:site_name" content="RealWire" />
	<meta property="og:image" content="https://www.realwire.com/twitter_writeitfiles/Be-Deutsche-Hospitality.jpg" /><meta property="og:image:secure_url" content="https://www.realwire.com/twitter_writeitfiles/Be-Deutsche-Hospitality.jpg" /><meta property="og:image:type" content="image/jpeg" />
	<meta property="og:image:width" content="600" /><meta property="og:image:height" content="400" />
	<meta property="og:type" content="article" />
	<meta property="article:published_time" content="2021-12-09T11:00:00Z" />
	
	<title>&#8220;BE Deutsche Hospitality&#8221; &#8211; exclusively for hotel partners, franchisees and investors </title>
	<meta http-equiv="X-UA-Compatible" content="IE=edge" />
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link href="https://www.realwire.com/rss/company.asp?c=211189020211209" rel="alternate" type="application/rss+xml" title="Recent releases for Deutsche Hospitality" />
	<!--[if lt IE 9]><script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script><![endif]-->
	<link rel="stylesheet" media="screen" href="includes/style.css?v=200823" />
	<!--[if IE]><link rel="stylesheet" media="screen" href="includes/screenIE.css" /><![endif]-->
	<!--[if IE 7]><link rel="stylesheet" media="screen" href="includes/screenIE7.css" /><![endif]-->
	<!--[if IE 8]><link rel="stylesheet" media="screen" href="includes/screenIE8.css" /><![endif]-->
	<!--[if IE 9]><link rel="stylesheet" media="screen" href="includes/screenIE9.css" /><![endif]-->
	<link rel="shortcut icon" href="favicon.ico" />
	<script src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>
	<script>var showCC = false</script>
	<script src="includes/jquery.plugins.js"></script> 
	<script src="includes/jquery.tools.js?v=2018.3"></script>
	<script type="text/javascript" src="//apis.google.com/js/plusone.js"></script>
	<script type="text/JavaScript">
	<!--
	function MM_openBrWindow(theURL,winName,features) { //v2.0
	  window.open(theURL,winName,features);
	}
	//-->
	</script>
</head>

<body id="r54827" onLoad="">

<div id="wrapper">
	<header><span id="navHamburger" title="Navigation">Navigation Menu</span><nav id="topNav"><ul id="navLog"><li class="btn"><a href="https://www.realwire.com/login.asp" id="nl-cl"><div>Client Login</div></a></li><li class="btn"><a href="https://www.realwire.com/login_p.asp" id="nl-rl"><div>Receiver Login</div></a></li><li class="btn"><a href="https://www.realwire.com/clients/issue.asp" id="nl-ir"><div>Issue Release</div></a></li></ul><div id="navCol"><ul id="n1col"><li class="nTitle">Services</li><li><a href="https://www.realwire.com/process.asp">The Process</a></li><li><a href="https://www.realwire.com/servicesSMNR.asp">SMNR</a></li><li><a href="https://www.realwire.com/servicesPricing.asp">Pricing</a></li><li><a href="https://www.realwire.com/ourPartners.asp">Partners</a></li></ul><ul><li class="nTitle">Why RealWire?</li><li><a href="https://www.realwire.com/testimonials.asp">Testimonials</a></li><li><a href="https://www.realwire.com/RealShowcase.asp">RealShowcase</a></li><li><a href="https://www.realwire.com/knowledge.asp">Knowledge</a></li></ul><ul><li class="nTitle">About</li><li><a href="https://www.realwire.com/ourStory.asp">Our Story</a></li><li><a href="https://www.realwire.com/theTeam.asp">The Team</a></li><li><a href="https://www.realwire.com/realwireNews.asp">RealWire News</a></li></ul><ul><li class="nTitle">Contact</li><li><a href="https://www.realwire.com/contact.asp">Enquiries</a></li><li><a href="https://www.realwire.com/sendSignup.asp">PR Sign Up</a></li><li><a href="https://www.realwire.com/receiveSignup.asp">Receiver Sign Up</a></li><li><a href="https://www.realwire.com/twitter/">Twitter Feeds</a></li></ul></div></nav><a href="https://www.realwire.com/" id="logoL">RealWire Limited</a><h2 id="logoStrap">Delivering&nbsp;Relevance, Releasing&nbsp;Influence</h2><div id="navBar"><div id="nbLinks"><a href="https://www.realwire.com/sendSignup.asp">Send Release</a>|<a href="https://www.realwire.com/receiveSignup.asp">Receive Releases</a>|<a href="https://www.realwire.com/archive.asp">Archive</a>|<a href="https://www.realwire.com/FAQ.asp">FAQ's</a></div><div id="nbSocial"><a href="https://www.realwire.com/rss/feeds.asp" class="icoRSS" title="RSS Feeds">RSS</a><a href="https://www.realwire.com/twitter/" class="icoTwitter" title="Twitter Feeds">Twitter</a><a href="https://www.linkedin.com/company/realwire" target="_blank" class="icoLinkedIn" title="LinkedIn Page">LinkedIn</a><a href="https://vimeo.com/realwire/" target="_blank" class="icoVimeo" title="Videos on Vimeo">Vimeo</a><a href="https://www.youtube.com/realwire" target="_blank" class="icoYouTube" title="Videos on YouTube">YouTube</a></div></div></header>
	<div id="col1" class="content info">
		<div id="releaseHead">
			
			<div id="releaseShare">
				<a href="https://twitter.com/share" rel="nofollow" onClick="window.open('https://twitter.com/share?url=http%3A%2F%2Frlw%2Eco%2FcQS&amp;counturl=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2FBE%2DDeutsche%2DHospitality%2Dexclusively%2Dfor%2Dhotel%2Dpartners&amp;text=%26%238220%3BBE+Deutsche+Hospitality%26%238221%3B+%26%238211%3B+exclusively+for+hotel+partners%2C+franchisees+and+investors+&amp;related=RealWire', 'twitter','toolbar=no,width=550,height=450'); return false;" class="shareTwit_w">Tweet</a>
				<script>function fbs_click() {u=location.href;t=document.title;window.open('http://www.facebook.com/sharer.php?u='+encodeURIComponent(u)+'&t='+encodeURIComponent(t),'sharer','toolbar=0,status=0,width=626,height=436');return false;}</script><a href="http://www.facebook.com/share.php?u=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2FBE%2DDeutsche%2DHospitality%2Dexclusively%2Dfor%2Dhotel%2Dpartners" onClick="return fbs_click()" target="_blank" class="shareFB_w">Facebook</a>
				<a href="http://www.linkedin.com/shareArticle" rel="nofollow" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2FBE%2DDeutsche%2DHospitality%2Dexclusively%2Dfor%2Dhotel%2Dpartners&amp;title=%26%238220%3BBE+Deutsche+Hospitality%26%238221%3B+%26%238211%3B+exclusively+for+hotel+partners%2C+franchisees+and+investors+&amp;source=https%3A%2F%2Fwww%2Erealwire%2Ecom', 'linkedIn','toolbar=no,scrollbars=yes,width=577,height=420'); return false;" class="shareLinkedIn_w">LinkedIn</a>
				<span class="g_Plus_btn"></span>
			</div>
			Press Release
			<hr />
			
		</div>

		
		<h1>&#8220;BE Deutsche Hospitality&#8221; &#8211; exclusively for hotel partners, franchisees and investors </h1>
		<div id="moMediaBar">
			<div id="moMediaMenu" class="moArea">
				<div class="cssBtn" onClick="releseInfoBtn('Media')">Media</div>
			</div>
			<div id="moLinksMenu" class="moArea">
				<div class="cssBtn" onClick="releseInfoBtn('Links')">Links</div>
			</div>
				<div id="moMediaArea" class="moAreas"></div>
				<div id="moLinksArea" class="moAreas"></div>
		</div>
<!--sub heading here h2-->
		<article><!-- Article Start --></p><p><p><em>Deutsche Hospitality offers new service solutions and a transparent fee model</em></p><p><strong>Frankfurt am Main, 9 December 2021</strong> Deutsche Hospitality is undertaking a massive expansion of the services it provides to hotel partners and investors in the areas of franchise, management and lease agreements. The new &#8220;BE Deutsche Hospitality&#8221; partner programme sends out clear impetuses to the sector. The hotel industry continues to offer considerable areas of potential for successful investments if the right ties are in place with an expert ally. To this end, Deutsche Hospitality has put together a new service concept containing a host of digital solutions which are precisely tailored to the needs of its hotel partners. Everything has been combined to form an all-in package.</p><div style="margin-left:0px;float:left;width:246px;"><div style="text-align:center;"><img style="margin:5px 10px 10px 0;border:1px solid #879690;" src="https://www.realwire.com/preview_writeitfiles/Be-Deutsche-Hospitality.jpg" alt="BE Deutsche Hospitality" title="BE Deutsche Hospitality"></div><div style="text-align:center;clear:both;margin:1px 10px;font-weight:bold;font-size:smaller;width:250;">BE Deutsche Hospitality</div></div><p>&#8220;Our &#8216;BE Deutsche Hospitality&#8217; partner programme is an attractive opportunity for hoteliers, hotel operators, investors and individual companies in the hospitality sector to become part of our brand portfolio and to grow alongside us,&#8221; said Marcus Bernhardt, CEO of Deutsche Hospitality. &#8220;This new programme represents the implementation of a fresh type of customer-oriented provision which encompasses all types of contracts. A focus is being placed on future franchisees by providing them with the chance to integrate into our network within a short space of time.&#8221;</p><p>Kai H. Gehrmann, Vice President Franchise, Deutsche Hospitality, added: &#8220;The programme comprises easily calculable structures and business solutions delivered from a single source and extending across sales, marketing and communications, IT, digital commerce, operations, procurement, human resources and controlling. Digital solutions are a particular area in which Deutsche Hospitality is using new technologies to create benefits for partners and franchisees.&#8221; A multitude of smart applications will guarantee efficient operations and a digital customer journey right across every aspect. App-based check-in processes, e-housekeeping and digital back-office functions have all been incorporated.</p><p>&#8220;BE Deutsche Hospitality&#8221; will thus enable partners to take advantage of innovative digital solutions, establish sales structures on international markets and create successful hotel brands which enjoy high degrees of awareness and customer satisfaction. This performance package takes in the three pillars of core services, booking services and supplementary selective service options. It is available to all hotel segments from Luxury to Economy. The selective element allows partners to act in a targeted and cost-efficient way by choosing to use the services they require. Partners can access the services of the programme either as a complete package or as modular solutions. They will also profit from the growing cross-brand H Rewards loyalty scheme, which offers appealing partner conditions and attractive guest bonuses.</p><p>The new &#8220;BE Deutsche Hospitality&#8221; partner programme also launches a particularly transparent fee model which consists of three components. A turnover-related core fee applies to use of the brand and to the standard services associated with marketing and with hotel operations for the respective brands. The booking fee is only incurred if bookings are generated. Selective services are also only charged if actually used by the partner.</p><p>Deutsche Hospitality is based in Frankfurt am Main. Its eight extraordinary brands map out all relevant hotel segments under a single umbrella. The relevant segments are Luxury Lifestyle (Steigenberger Icons and Steigenberger Porsche Design Hotels), Upscale (Steigenberger Hotels &amp; Resorts, House of Beats and Jaz in the City), Midscale (MAXX by Deutsche Hospitality and IntercityHotel) and Economy (Zleep Hotels). The company can look back on a long tradition of welcoming guests. The values it encapsulates include vision, passion and cosmopolitanism.</p><p>Current press information is available in our <a href="https://www.deutschehospitality.com/presse" target="_blank" rel="nofollow noopener noopener">press portal</a>.</p><p>Vision, passion and cosmopolitanism. Deutsche Hospitality delivers the perfect guest experience. Tradition and an eye for the future come together in an inimitable portfolio of eight brands operating across more than 160 hotels globally. &#8220;Celebrating luxurious simplicity.&#8221; Steigenberger Icons are extraordinary luxury hotels which combine historical uniqueness and modern concepts. The Steigenberger Porsche Design Hotels brand is generating innovative impetuses in the Luxury Lifestyle Segment. Steigenberger Hotels &amp; Resorts represent the epitome of upscale hospitality on three continents. Jaz in the City&#8217;s Lifestyle Hotels dictate the rhythm in the Upscale Sector. House of Beats unites a passion for the hotel business with the fascination of lifestyle, fashion and music. IntercityHotel is located at the very hub of any destination and offers a true home of comfort and mobility in the Midscale Segment. MAXX by Deutsche Hospitality is a charismatic conversion brand which is also positioned in the midscale area of the market. Zleep Hotels provide a smart marriage of design and functionality in the Economy Segment. All of these brands are unified under H-Rewards, Deutsche Hospitality&#8217;s Loyalty Programme which yields benefits from the first booking onwards. The vision is clear. In conjunction with its shareholder Huazhu, Deutsche Hospitality aims to advance to become one of Europe&#8217;s leading hotel companies.</p><p><strong>Press contact </strong><br />Deutsche Hospitality &#9474; Lyoner Stra&szlig;e 25 &#9474; 60528 Frankfurt am Main<br />Sven Hirschler &#9474; Tel: +49 69 66564-422 <br />E-mail: <a href="mailto:sven.hirschler@deutschehospitality.com" target="_blank" rel="nofollow noopener">sven.hirschler@deutschehospitality.com</a></p><p><a href="https://www.facebook.com/deutschehospitality" target="_blank" rel="nofollow noopener noopener">Facebook</a> <a href="https://twitter.com/Dehospitality" target="_blank" rel="nofollow noopener noopener">Twitter</a> <a href="https://www.youtube.com/channel/UC52Xq3Yw8QS9nLY6BKs4Cvw" target="_blank" rel="nofollow noopener noopener">YouTube</a><br /><br /><a href="http://www.deutschehospitality.com" target="_blank" rel="nofollow noopener">www.deutschehospitality.com</a></p><!-- Article End --></article>
			
	</div>
	<nav id="col2" class="mediaBar info">
		
		<div class="secTitle">Issue Date
		</div>
		<div id="pub-date-div"><time dateTime="2021-12-09" pubdate="pubdate" id="pub-date">9 Dec 2021</time></div>
		<hr />
		<!--start multimedia-->
		<div id="additionMedia"><div class="secTitle">Images</div><div style="margin-bottom:20px;"><a href="/realResource.asp?ReleaseID=54827&amp;d=w&amp;name=Be%2DDeutsche%2DHospitality%2Ejpg&amp;title=BE%20Deutsche%20Hospitality" target="_blank"><img src="https://www.realwire.com/thumb_writeitfiles/Be-Deutsche-Hospitality.jpg" alt="BE Deutsche Hospitality" title="view BE Deutsche Hospitality" /></a><br />BE Deutsche Hospitality<br /><a href="/realResource.asp?ReleaseID=54827&amp;d=w&amp;name=Be%2DDeutsche%2DHospitality%2Ejpg&amp;title=BE%20Deutsche%20Hospitality" target="_blank" title="view BE Deutsche Hospitality">view</a></div><hr /></div>
		<!--End multimedia-->
		
		<div id="additionLinks"><div style="margin-bottom:20px;"><div class="secTitle">Related Links</div>
<a href="https://www.deutschehospitality.com/homepage" rel="nofollow" target="_blank">Deutsche Hospitality homepage </a><br /><a href="http://" rel="nofollow" target="_blank"></a><br /></div><hr />
<div><div class="secTitle">Categories</div>
<a href="results.asp?catI=12&catD=Business&cat=12,517,560,561,721,678,706,515,563,70,529,715,602,609,562,161,239">Business</a><br /><a href="results.asp?catI=415&catD=Travel&cat=415,414,528,748,526,725,416,417,527,749,525">Travel</a><br /></div><hr />

		<!--RSS FEED-->
		<div class="secTitle">Release Feed</div>
		<a href="/rss/company.asp?c=211189020211209" class="iconpad"><span class="shareRSS">RSS Feed</span>Deutsche Hospitality Feed</a>
		<hr />
		</div><!--end additionLinks-->
		<!--share release-->
		<div class="secTitle">Share Release</div>
		<span class="g_Plus_btn"></span>
		<script src="//platform.twitter.com/widgets.js" type="text/javascript"></script>
		<a href="https://twitter.com/share" rel="nofollow" onClick="window.open('https://twitter.com/share?url=http%3A%2F%2Frlw%2Eco%2FcQS&amp;counturl=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2FBE%2DDeutsche%2DHospitality%2Dexclusively%2Dfor%2Dhotel%2Dpartners&amp;text=%26%238220%3BBE+Deutsche+Hospitality%26%238221%3B+%26%238211%3B+exclusively+for+hotel+partners%2C+franchisees+and+investors+&amp;related=RealWire', 'twitter','toolbar=no,width=550,height=450'); return false;" class="shareTwit">Tweet</a>
		<script>function fbs_click() {u=location.href;t=document.title;window.open('http://www.facebook.com/sharer.php?u='+encodeURIComponent(u)+'&t='+encodeURIComponent(t),'sharer','toolbar=0,status=0,width=626,height=436');return false;}</script><a href="http://www.facebook.com/share.php?u=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2FBE%2DDeutsche%2DHospitality%2Dexclusively%2Dfor%2Dhotel%2Dpartners" onClick="return fbs_click()" target="_blank" class="shareFB">Facebook</a>
		<a href="http://www.linkedin.com/shareArticle" rel="nofollow" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2FBE%2DDeutsche%2DHospitality%2Dexclusively%2Dfor%2Dhotel%2Dpartners&amp;title=%26%238220%3BBE+Deutsche+Hospitality%26%238221%3B+%26%238211%3B+exclusively+for+hotel+partners%2C+franchisees+and+investors+&amp;source=https%3A%2F%2Fwww%2Erealwire%2Ecom', 'linkedIn','toolbar=no,scrollbars=yes,width=577,height=420'); return false;" class="shareLinkedIn">LinkedIn</a>
		<br />
		<a target="_blank" rel="nofollow" href="http://www.blinklist.com/index.php?Action=Blink/addblink.php&amp;Description=&amp;url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2FBE%2DDeutsche%2DHospitality%2Dexclusively%2Dfor%2Dhotel%2Dpartners&amp;title=%26%238220%3BBE+Deutsche+Hospitality%26%238221%3B+%26%238211%3B+exclusively+for+hotel+partners%2C+franchisees+and+investors+&amp;Tag=" class="shareBlink">blink it</a>
		<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2FBE%2DDeutsche%2DHospitality%2Dexclusively%2Dfor%2Dhotel%2Dpartners" rel="nofollow" target="_blank" class="shareRedit">Reddit!</a>
		<a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2FBE%2DDeutsche%2DHospitality%2Dexclusively%2Dfor%2Dhotel%2Dpartners&amp;title=%26%238220%3BBE+Deutsche+Hospitality%26%238221%3B+%26%238211%3B+exclusively+for+hotel+partners%2C+franchisees+and+investors+" rel="nofollow" target="_blank" class="shareStumble">Stumble It!</a>
		<a href="http://www.diigo.com" rel="nofollow" onClick="var s=document.createElement('script');s.type='text/javascript';s.src='https://www.diigo.com/javascripts/webtoolbar/diigolet_b_h_b.js';document.body.appendChild(s);return false;" class="shareDiigo">Add to Diigo</a>
		<a href="http://www.delicious.com/save" rel="nofollow" onClick="window.open('http://www.delicious.com/save?v=5&amp;noui&amp;jump=close&amp;url='+encodeURIComponent(location.href)+'&amp;title='+encodeURIComponent(document.title), 'delicious','toolbar=no,width=560,height=550'); return false;" class="shareDelicious">Bookmark this on Delicious</a>
<!--Editorial Contacts Here-->
		
	</nav>
	<div class="push"></div>
</div>
<footer><div id="footerContent"><nav><div id="ftContact"><div id="ftLogo"></div><span>Contact us</span> +44 (0)1522 883640</div><strong>Follow us</strong><div id="ftFind"><a href="http://www.realwire.com/rss/feeds.asp" class="icoRSS" title="RSS Feeds">RSS</a><a href="http://www.realwire.com/twitter/" class="icoTwitter" title="Twitter Feeds">Twitter</a><a href="http://www.linkedin.com/company/realwire" target="_blank" class="icoLinkedIn" title="LinkedIn Page">LinkedIn</a><a href="http://vimeo.com/realwire/" target="_blank" class="icoVimeo" title="Videos on Vimeo">Vimeo</a><a href="http://www.youtube.com/realwire" class="icoYouTube" target="_blank" title="Videos on YouTube">YouTube</a></div><div id="ftInfo"><div id="ftCopy"><a href="../siteCopyright.asp">Copyright &copy; 2011 - 2021 Realwire Limited, all rights reserved</a>.</div><a href="http://www.realwire.com/sitePrivacyPolicy.asp">Privacy Policy</a>&nbsp;&nbsp;&nbsp;|&nbsp;&nbsp;&nbsp;<a href="http://www.realwire.com/siteGDPR.asp">GDPR Policy</a>&nbsp;&nbsp;&nbsp;|&nbsp;&nbsp;&nbsp;<a href="http://www.realwire.com/siteDisclaimer.asp">Disclaimer</a></div></nav></div></footer><script type="text/javascript">var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));</script>
</body>
</html>
