
<!doctype html>
<html>
<head>
	<meta charset="utf-8">
	<base href="https://www.realwire.com/" />

	<meta name="title" content="telent selected to deliver major performance upgrade and security enhancement for Channel Island&#8217;s telecom network" />
	<meta name="description" content="Upgrade in Guernsey will enable Sure to meet demand and future-proof its quadruple play business for future growth in the market
Warwick, UK, and Guernsey, 01 June 2020: telent Technology Services Ltd..." />
	<link rel="canonical" href="https://www.realwire.com/releases/telent-selected-to-deliver-major-performance-upgrade" />
	<meta name="keywords" content="" />
	<meta name="robots" content="NOODP" />
	<meta name="medium" content="news" />
	<link rel="image_src" href="https://www.realwire.com/images/logo.gif" />
	<meta name="twitter:card" content="summary_large_image" /><meta name="twitter:image" content="https://www.realwire.com/twitter_writeitfiles/releasedByRealwire.jpg?v1.1" /><meta name="twitter:image:width" content="500" /><meta name="twitter:image:height" content="250" />
	<meta name="twitter:site" content="@RealWire" />
	<meta property="og:title" content="telent | telent selected to deliver major performance upgrade and security enhancement for Channel Island&#8217;s telecom network" />
	<meta property="og:description" content="Upgrade in Guernsey will enable Sure to meet demand and future-proof its quadruple play business for future growth in the market
Warwick, UK, and Guernsey, 01 June 2020: telent Technology Services Ltd" />
	<meta property="og:url" content="https://www.realwire.com/releases/telent-selected-to-deliver-major-performance-upgrade" />
	<meta property="og:site_name" content="RealWire" />
		<meta property="og:image" content="http://www.realwire.com/images/logo.jpg" /><meta property="og:image:secure_url" content="https://www.realwire.com/images/logo.jpg" /><meta property="og:image:type" content="image/jpeg" /><meta property="og:image:width" content="305" /><meta property="og:image:height" content="60" />
	<meta property="og:type" content="article" />
	<meta property="article:published_time" content="2020-06-01T12:45:00Z" />
	
	<title>telent selected to deliver major performance upgrade and security enhancement for Channel Island&#8217;s telecom network</title>
	<meta http-equiv="X-UA-Compatible" content="IE=edge" />
	<link href="https://www.realwire.com/rss/company.asp?c=27828220200601" rel="alternate" type="application/rss+xml" title="Recent releases for telent" />
	<!--[if lt IE 9]><script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script><![endif]-->
	<link rel="stylesheet" media="screen" href="includes/style.css" />
	<!--[if IE]><link rel="stylesheet" media="screen" href="includes/screenIE.css" /><![endif]-->
	<!--[if IE 7]><link rel="stylesheet" media="screen" href="includes/screenIE7.css" /><![endif]-->
	<!--[if IE 8]><link rel="stylesheet" media="screen" href="includes/screenIE8.css" /><![endif]-->
	<!--[if IE 9]><link rel="stylesheet" media="screen" href="includes/screenIE9.css" /><![endif]-->
	<link rel="shortcut icon" href="favicon.ico" />
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<script src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>
	<script>var showCC = false</script>
	<script src="includes/jquery.plugins.js"></script> 
	<script src="includes/jquery.tools.js?v=2018.3"></script>
	<script type="text/javascript" src="//apis.google.com/js/plusone.js"></script>
	<script type="text/JavaScript">
	<!--
	function MM_openBrWindow(theURL,winName,features) { //v2.0
	  window.open(theURL,winName,features);
	}
	//-->
	</script>
</head>

<body id="r52148" onLoad="">

<div id="wrapper">
	<header><span id="navHamburger" title="Navigation">Navigation Menu</span><nav id="topNav"><ul id="navLog"><li class="btn"><a href="https://www.realwire.com/login.asp" id="nl-cl"><div>Client Login</div></a></li><li class="btn"><a href="https://www.realwire.com/login_p.asp" id="nl-rl"><div>Receiver Login</div></a></li><li class="btn"><a href="https://www.realwire.com/clients/issue.asp" id="nl-ir"><div>Issue Release</div></a></li></ul><div id="navCol"><ul id="n1col"><li class="nTitle">Services</li><li><a href="https://www.realwire.com/process.asp">The Process</a></li><li><a href="https://www.realwire.com/servicesSMNR.asp">SMNR</a></li><li><a href="https://www.realwire.com/servicesPricing.asp">Pricing</a></li><li><a href="https://www.realwire.com/ourPartners.asp">Partners</a></li></ul><ul><li class="nTitle">Why RealWire?</li><li><a href="https://www.realwire.com/testimonials.asp">Testimonials</a></li><li><a href="https://www.realwire.com/realStory.asp">RealStories</a></li><li><a href="https://www.realwire.com/knowledge.asp">Knowledge</a></li></ul><ul><li class="nTitle">About</li><li><a href="https://www.realwire.com/ourStory.asp">Our Story</a></li><li><a href="https://www.realwire.com/theTeam.asp">The Team</a></li><li><a href="https://www.realwire.com/realwireNews.asp">RealWire News</a></li></ul><ul><li class="nTitle">Contact</li><li><a href="https://www.realwire.com/contact.asp">Enquiries</a></li><li><a href="https://www.realwire.com/sendSignup.asp">PR Sign Up</a></li><li><a href="https://www.realwire.com/receiveSignup.asp">Receiver Sign Up</a></li><li><a href="https://www.realwire.com/twitter/">Twitter Feeds</a></li></ul></div></nav><a href="https://www.realwire.com/" id="logoL">RealWire Limited</a><h2 id="logoStrap">Delivering&nbsp;Relevance, Releasing&nbsp;Influence</h2><div id="navBar"><div id="nbLinks"><a href="https://www.realwire.com/sendSignup.asp">Send Release</a>|<a href="https://www.realwire.com/receiveSignup.asp">Receive Releases</a>|<a href="https://www.realwire.com/archive.asp">Archive</a>|<a href="https://www.realwire.com/FAQ.asp">FAQ's</a></div><div id="nbSocial"><a href="https://www.realwire.com/rss/feeds.asp" class="icoRSS" title="RSS Feeds">RSS</a><a href="https://www.realwire.com/twitter/" class="icoTwitter" title="Twitter Feeds">Twitter</a><a href="https://www.linkedin.com/company/realwire" target="_blank" class="icoLinkedIn" title="LinkedIn Page">LinkedIn</a><a href="https://vimeo.com/realwire/" target="_blank" class="icoVimeo" title="Videos on Vimeo">Vimeo</a><a href="https://www.youtube.com/realwire" target="_blank" class="icoYouTube" title="Videos on YouTube">YouTube</a></div></div></header>
	<div id="col1" class="content info">
		<div id="releaseHead">
			
			<div id="releaseShare">
				<a href="https://twitter.com/share" rel="nofollow" onClick="window.open('https://twitter.com/share?url=http%3A%2F%2Frlw%2Eco%2FbSP&amp;counturl=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2Ftelent%2Dselected%2Dto%2Ddeliver%2Dmajor%2Dperformance%2Dupgrade&amp;text=telent+selected+to+deliver+major+performance+upgrade+and+security+enhancement+for+Channel+Island%26%238217%3Bs+telecom+network&amp;related=RealWire', 'twitter','toolbar=no,width=550,height=450'); return false;" class="shareTwit_w">Tweet</a>
				<script>function fbs_click() {u=location.href;t=document.title;window.open('http://www.facebook.com/sharer.php?u='+encodeURIComponent(u)+'&t='+encodeURIComponent(t),'sharer','toolbar=0,status=0,width=626,height=436');return false;}</script><a href="http://www.facebook.com/share.php?u=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2Ftelent%2Dselected%2Dto%2Ddeliver%2Dmajor%2Dperformance%2Dupgrade" onClick="return fbs_click()" target="_blank" class="shareFB_w">Facebook</a>
				<a href="http://www.linkedin.com/shareArticle" rel="nofollow" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2Ftelent%2Dselected%2Dto%2Ddeliver%2Dmajor%2Dperformance%2Dupgrade&amp;title=telent+selected+to+deliver+major+performance+upgrade+and+security+enhancement+for+Channel+Island%26%238217%3Bs+telecom+network&amp;source=https%3A%2F%2Fwww%2Erealwire%2Ecom', 'linkedIn','toolbar=no,scrollbars=yes,width=577,height=420'); return false;" class="shareLinkedIn_w">LinkedIn</a>
				<span class="g_Plus_btn"></span>
			</div>
			Press Release
			<hr />
			
		</div>

		
		<h1>telent selected to deliver major performance upgrade and security enhancement for Channel Island&#8217;s telecom network</h1>
		<div id="moMediaBar">
			<div id="moMediaMenu" class="moArea">
				<div class="cssBtn" onClick="releseInfoBtn('Media')">Media</div>
			</div>
			<div id="moLinksMenu" class="moArea">
				<div class="cssBtn" onClick="releseInfoBtn('Links')">Links</div>
			</div>
				<div id="moMediaArea" class="moAreas"></div>
				<div id="moLinksArea" class="moAreas"></div>
		</div>
<!--sub heading here h2-->
		<article><!-- Article Start --><p><em>Upgrade in Guernsey will enable Sure to meet demand and future-proof its quadruple play business for future growth in the market</em></p>
<p><strong>Warwick, UK, and Guernsey, 01 June 2020</strong>: <a href="https://telent.com/" target="_blank" rel="nofollow noopener noopener">telent Technology Services Ltd.</a> (telent), a leading UK technology and network services company, has been awarded a contract by <a href="https://www.sure.com/" target="_blank" rel="nofollow noopener noopener">Sure</a> to upgrade the service provider&#8217;s network and enhance its network security.</p>
<p>The major upgrade will see telent replace Sure&#8217;s existing 10G core network with a 100G <a href="https://www.juniper.net/uk/en/" target="_blank" rel="nofollow noopener noopener">Juniper Networks</a> core network. This will allow Sure to deliver faster, more reliable internet connectivity to its consumer and business customers across the island as increasing bandwidth usage and data create unprecedented demand.</p>
<p>The network implementation will provide extra capacity for growth and will future-proof the network as growing and new technologies, including Fibre-to-the-home (FTTH) and 5G, are rolled out commercially. As a core network, it will also deliver increased capacity to London and Paris, connecting the islands to the rest of the world.</p>
<p>In addition, to ensure the integrity and security of the network is not compromised, telent will implement a joint Juniper-Corero Distributed Denial of Service (DDoS) solution to provide real time, automated DDoS protection.</p>
<p>&#8220;The current situation is a clear reminder that telecoms are a key and growing component of our economy and daily lives,&#8221; said Sure Group CEO Ian Kelly. &#8220;This network upgrade is a significant long-term investment to ensure we can continue to meet customer expectations now and in the future. We are pleased to be working with telent which has a long history and strong reputation in the design, upgrade, build and maintenance of critical networks.&#8221;</p>
<p>As well as protecting the network, the Juniper-Corero solution will allow Sure to sell &#8220;clean pipes&#8221; &#8211; meaning DDoS protected circuits. This means that Sure&#8217;s customers will be able to benefit from enhanced connectivity performance while having additional assurance that the network is protected and secure. Work on the project has already started and is expected to be completed by early 2021.</p>
<p>Sure chose telent due to its history and expertise in the Tier 1 Service Provider market, and its experience of delivering similar projects with Juniper Networks in a turnkey manner. This includes professional services such as the delivery of high and low level design, testing, installations and commissioning. Under the agreement with Sure, these services will be backed by a stringent Service Level Agreement (SLA) support and maintenance model across the network in Guernsey, Jersey, Paris and London.</p>
<p>&#8220;Growing data consumption means demand for higher network capacity and speed is growing and service providers must ensure they are delivering on that,&#8221; said Shani Latif, Sales Director at telent. &#8220;This upgrade for Sure will incorporate the latest technologies to ensure a future-proof network, while our experience and knowledge of the service provider market will minimise customer disruption and ensure work is completed efficiently.&#8221;</p>
<p>For more information about telent&#8217;s work, please visit: <a href="http://www.telent.com" target="_blank" rel="nofollow noopener">www.telent.com</a>.</p>
<p>- ENDS -</p>
<p><strong>About telent</strong><br />Dedicated to defining the ever-changing digital landscape, telent designs and delivers solutions and services that enable organisations to create, improve and maintain their mission critical communications networks.</p>
<p>Vital in the effective operation of the nation&#8217;s infrastructure and at the heart of many of the UK&#8217;s and Ireland&#8217;s best-known brands, telent operates within various industry sectors, including Transport, Service Provider, Public Safety, Defence, Government/Public Services and Enterprise.</p>
<p>telent&#8217;s industry expertise and professionalism make the company a partner of choice for organisations at the forefront of the digital revolution. telent was recently appointed as the new supplier to Highways England to operate and manage the National Roads Telecommunications Service, a vital component of the UK&#8217;s critical national infrastructure.</p>
<p>Clients include Highways England, Transport for London, Kent County Council, West Sussex County Council, Gloucestershire County Council, Network Rail, BAE Systems, BT, Interoute, London Ambulance Service, Merseyside Fire &amp; Rescue, RNLI, Maritime Coast Guard Agency, Metropolitan Police, Sky, and Virgin Media.</p>
<p>Additional information can be found at <a href="http://www.telent.com" target="_blank" rel="nofollow noopener">www.telent.com</a>.</p>
<p>Twitter: <a href="https://twitter.com/telent_UK" target="_blank" rel="nofollow noopener noopener">@telent_UK</a><br />LinkedIn: <a href="http://www.linkedin.com/company/telent" target="_blank" rel="nofollow noopener">www.linkedin.com/company/telent</a></p>
<p><strong>Media Contact</strong><br />Proactive PR<br />Tel: +44 1636 704888<br />Email: <a href="mailto:telent@proactive-pr.com" target="_blank" rel="nofollow noopener">telent@proactive-pr.com</a></p><!-- Article End --></article>
			
	</div>
	<nav id="col2" class="mediaBar info">
		
		<div class="secTitle">Issue Date
		</div>
		<div id="pub-date-div"><time dateTime="2020-06-01" pubdate="pubdate" id="pub-date">1 Jun 2020</time></div>
		<hr />
		<!--start multimedia-->
		<div id="additionMedia"></div>
		<!--End multimedia-->
		
		<div id="additionLinks"><div style="margin-bottom:20px;"><div class="secTitle">Related Links</div>
<a href="https://telent.com/" rel="nofollow" target="_blank">telent homepage </a><br /><a href="https://www.sure.com/" rel="nofollow" target="_blank"> Sure homepage </a><br /><a href="http://" rel="nofollow" target="_blank"></a><br /></div><hr />
<div><div class="secTitle">Categories</div>
<a href="results.asp?catI=352&catD=IT&cat=352,695,699,118,209,261,143,771,262,552,577,718,709,727,195,158,164,60,698,68,697,366,72,153,233,468,208,30,162,369,234,708,323,112,624,235,141,355,702,110,701,558,378,712,726,520,133,511,192,165,130,113,75,710,40,554,295,294,197,386,696,597,711,318,392,47,199,134,728,129,293,382,61,320,125,521,555,21,326,136,321,259,107">IT</a><br /><a href="results.asp?catI=349&catD=Telecom&cat=349,48,625,717,619,588,668,56,170,65,42,655,29,268,73,28,38,205,50,24,470,617,745,168,471,152,388,328,242,535,19,643,131,387,17,46,135,250,132,742,147,115,241,18,71">Telecom</a><br /></div><hr />

		<!--RSS FEED-->
		<div class="secTitle">Release Feed</div>
		<a href="/rss/company.asp?c=27828220200601" class="iconpad"><span class="shareRSS">RSS Feed</span>telent Feed</a>
		<hr />
		</div><!--end additionLinks-->
		<!--share release-->
		<div class="secTitle">Share Release</div>
		<span class="g_Plus_btn"></span>
		<script src="//platform.twitter.com/widgets.js" type="text/javascript"></script>
		<a href="https://twitter.com/share" rel="nofollow" onClick="window.open('https://twitter.com/share?url=http%3A%2F%2Frlw%2Eco%2FbSP&amp;counturl=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2Ftelent%2Dselected%2Dto%2Ddeliver%2Dmajor%2Dperformance%2Dupgrade&amp;text=telent+selected+to+deliver+major+performance+upgrade+and+security+enhancement+for+Channel+Island%26%238217%3Bs+telecom+network&amp;related=RealWire', 'twitter','toolbar=no,width=550,height=450'); return false;" class="shareTwit">Tweet</a>
		<script>function fbs_click() {u=location.href;t=document.title;window.open('http://www.facebook.com/sharer.php?u='+encodeURIComponent(u)+'&t='+encodeURIComponent(t),'sharer','toolbar=0,status=0,width=626,height=436');return false;}</script><a href="http://www.facebook.com/share.php?u=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2Ftelent%2Dselected%2Dto%2Ddeliver%2Dmajor%2Dperformance%2Dupgrade" onClick="return fbs_click()" target="_blank" class="shareFB">Facebook</a>
		<a href="http://www.linkedin.com/shareArticle" rel="nofollow" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2Ftelent%2Dselected%2Dto%2Ddeliver%2Dmajor%2Dperformance%2Dupgrade&amp;title=telent+selected+to+deliver+major+performance+upgrade+and+security+enhancement+for+Channel+Island%26%238217%3Bs+telecom+network&amp;source=https%3A%2F%2Fwww%2Erealwire%2Ecom', 'linkedIn','toolbar=no,scrollbars=yes,width=577,height=420'); return false;" class="shareLinkedIn">LinkedIn</a>
		<br />
		<a target="_blank" rel="nofollow" href="http://www.blinklist.com/index.php?Action=Blink/addblink.php&amp;Description=&amp;url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2Ftelent%2Dselected%2Dto%2Ddeliver%2Dmajor%2Dperformance%2Dupgrade&amp;title=telent+selected+to+deliver+major+performance+upgrade+and+security+enhancement+for+Channel+Island%26%238217%3Bs+telecom+network&amp;Tag=" class="shareBlink">blink it</a>
		<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2Ftelent%2Dselected%2Dto%2Ddeliver%2Dmajor%2Dperformance%2Dupgrade" rel="nofollow" target="_blank" class="shareRedit">Reddit!</a>
		<a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww%2Erealwire%2Ecom%2Freleases%2Ftelent%2Dselected%2Dto%2Ddeliver%2Dmajor%2Dperformance%2Dupgrade&amp;title=telent+selected+to+deliver+major+performance+upgrade+and+security+enhancement+for+Channel+Island%26%238217%3Bs+telecom+network" rel="nofollow" target="_blank" class="shareStumble">Stumble It!</a>
		<a href="http://www.diigo.com" rel="nofollow" onClick="var s=document.createElement('script');s.type='text/javascript';s.src='https://www.diigo.com/javascripts/webtoolbar/diigolet_b_h_b.js';document.body.appendChild(s);return false;" class="shareDiigo">Add to Diigo</a>
		<a href="http://www.delicious.com/save" rel="nofollow" onClick="window.open('http://www.delicious.com/save?v=5&amp;noui&amp;jump=close&amp;url='+encodeURIComponent(location.href)+'&amp;title='+encodeURIComponent(document.title), 'delicious','toolbar=no,width=560,height=550'); return false;" class="shareDelicious">Bookmark this on Delicious</a>
<!--Editorial Contacts Here-->
		
	</nav>
	<div class="push"></div>
</div>
<footer><div id="footerContent"><nav><div id="ftContact"><div id="ftLogo"></div><span>Contact us</span> +44 (0)1522 883640</div><strong>Follow us</strong><div id="ftFind"><a href="http://www.realwire.com/rss/feeds.asp" class="icoRSS" title="RSS Feeds">RSS</a><a href="http://www.realwire.com/twitter/" class="icoTwitter" title="Twitter Feeds">Twitter</a><a href="http://www.linkedin.com/company/realwire" target="_blank" class="icoLinkedIn" title="LinkedIn Page">LinkedIn</a><a href="http://vimeo.com/realwire/" target="_blank" class="icoVimeo" title="Videos on Vimeo">Vimeo</a><a href="http://www.youtube.com/realwire" class="icoYouTube" target="_blank" title="Videos on YouTube">YouTube</a></div><div id="ftInfo"><div id="ftCopy"><a href="../siteCopyright.asp">Copyright &copy; 2011 - 2020 Realwire Limited, all rights reserved</a>.</div><a href="http://www.realwire.com/sitePrivacyPolicy.asp">Privacy Policy</a>&nbsp;&nbsp;&nbsp;|&nbsp;&nbsp;&nbsp;<a href="http://www.realwire.com/siteGDPR.asp">GDPR Policy</a>&nbsp;&nbsp;&nbsp;|&nbsp;&nbsp;&nbsp;<a href="http://www.realwire.com/siteDisclaimer.asp">Disclaimer</a></div></nav></div></footer><script type="text/javascript">var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));</script>
</body>
</html>
